Opened 10 years ago

Closed 10 years ago

#9996 closed defect (fixed)

FileUpload widget fails to create in declarative markup

Reported by: Ian Fouls Owned by: Mike Wilcox
Priority: high Milestone: 1.4
Component: DojoX Form Version: 1.3.2
Keywords: FileUploader declarative Cc:
Blocked By: Blocking:

Description

When created via script the FileUploader? is created OK, however when identical parameters are used in declarative markup the create fails. In fact if the decalarative and script creation appear together they both fail.

The example is taken from the 1.3.2 document page and cleaned up, the doc page example is incorrect in that the class names in the styles are inconsistent with those used in the subsequent code.

A working example of both declarative and programatic creation actually on the doc page would be very desirable, just like other widgets!

Please see the attached test.html.

Attachments (2)

test.html (2.4 KB) - added by Ian Fouls 10 years ago.
file_upload_dialog_test.html (2.9 KB) - added by Ian Fouls 10 years ago.
Test to demonstrate issue in s dialog

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by Ian Fouls

Attachment: test.html added

comment:1 Changed 10 years ago by dante

Component: GeneralDojoX Form
Owner: changed from anonymous to Mike Wilcox

comment:2 Changed 10 years ago by Mike Wilcox

Milestone: tbd1.4
Resolution: fixed
Status: newclosed

comment:3 Changed 10 years ago by Ian Fouls

Resolution: fixed
Status: closedreopened

The fixes are OK provided the FileUploder? is not in a dialog, if it is it no longer displays the button.

Please see the attached test file file_uploader_dialog_test.html, this includes an uploader inside and outside of a dialog with the latter not being displayed.

Changed 10 years ago by Ian Fouls

Test to demonstrate issue in s dialog

comment:4 Changed 10 years ago by Ian Fouls

I'd just like to add that it also doesn't seem work within a dialog when programatically created either.

This is quite a pain for me as the FileInputAuto? widget doesn't support additional form data, they only way with the released code is a double upload. I think I'll submit a ticket and a hack to FileInputAuto? as it looks like an easy job to add a callback to add additional form elements to the form upload.

comment:5 Changed 10 years ago by Mike Wilcox

(In [20641]) Refs #10104, #9996, #9793, Fixes #10196 - fixed style regressions. Also added some groundwork for making FileUploader? work in Dialog and TabContainer? (the ability to be initially hidden... tricky task)

comment:6 Changed 10 years ago by Mike Wilcox

Resolution: fixed
Status: reopenedclosed

The dialog box is a different issue, tracked here: http://bugs.dojotoolkit.org/ticket/10313

Note: See TracTickets for help on using tickets.