Opened 10 years ago

Closed 10 years ago

#9992 closed defect (fixed)

Regression: ContentPane API (1.4)

Reported by: Chris Mitchell Owned by: bill
Priority: high Milestone: 1.4
Component: Dijit Version: 1.3.2
Keywords: Cc: Adam Peller
Blocked By: Blocking:

Description (last modified by bill)

By changing ContentPane into a full layout widget, the api: isLayoutContainer previously returned "false" for ContentPane instances. Since this api now returns "true" for ContentPanes, applications which made use of isLayoutContainer may behave differently in Dojo 1.4.

This is probably a rare case; however, it is known to have broken at least one large application that's doing early 1.4 testing on trunk, and should be documented as a "breaking change" in the release notes.

Change History (2)

comment:1 Changed 10 years ago by Adam Peller

Cc: Adam Peller added

comment:2 Changed 10 years ago by bill

Description: modified (diff)
Milestone: tbd1.4
Resolution: fixed
Status: newclosed

OK, fair enough, it was sort of documented before but just I added a line about the isLayoutContainer flag.

Note: See TracTickets for help on using tickets.