Opened 10 years ago

Closed 8 years ago

#9991 closed defect (duplicate)

Unable to check if object is an instance of dojo.NodeList

Reported by: Les Owned by: Eugene Lazutkin
Priority: low Milestone: future
Component: Core Version: 1.3.2
Keywords: dojo.NodeList needsreview Cc:
Blocked By: Blocking:

Description (last modified by bill)

I tried this code, but it returns false.

var list = new dojo.NodeList();
list instanceof dojo.NodeList;

... and list.isInstanceOf(dojo.NodeList) will not work either b/c dojo.NodeList is not dojo.declare'd.

Change History (3)

comment:1 Changed 10 years ago by bill

Component: GeneralCore
Description: modified (diff)
Milestone: tbdfuture
Owner: changed from anonymous to Eugene Lazutkin

Right, because NodeList isn't a class, just a name we've given to the type of Object that dojo.query() returns. Eugene feels strongly about this issue so assigning the ticket to him.

comment:2 Changed 8 years ago by ben hockey

Keywords: needsreview added

comment:3 Changed 8 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #10203.
Let's track this in #10203.

Version 0, edited 8 years ago by bill (next)
Note: See TracTickets for help on using tickets.