Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9987 closed defect (fixed)

RTE: Focus is not shifting back right on IE when using LinkDialog to insert/edit hyperlinks

Reported by: Jared Jurkiewicz Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Editor Version: 1.3.2
Keywords: Cc: Douglas Hays
Blocked By: Blocking:

Description

RTE: Focus is not shifting back right on IE when using LinkDialog? to insert/edit hyperlinks

This can be seen on:
http://archive.dojotoolkit.org/nightly/checkout/dijit/tests/editor/test_Editor.html and
http://archive.dojotoolkit.org/dojo-2009-09-24/dojotoolkit/dijit/tests/editor/test_Editor.html

In IE7 (And likely others. Select the editor with optional plugins (as it has the LinkDialog?).

Enter the iframe and press enter a few times to get a few newlines towards the end.

Click the insert link button (the little chain icon).

Enter something for url and description

Click set.

Dialog closes, but the link inserts to the top of the document, not the bottom as you would expect.

Also, if you select any text in the document, say the word 'cursive' and click the link button, it shows the 'cursive' text selected, ... but when you enter an http:// url to it and click set, again it inserts it at the top and doesn't replace the word 'cursive'.

So ...

Something is still very messed up with regard to selection restore on IE.

Assigning to Bill since he made changes in this area and is most familiar with it.

Will continue investigation

Attachments (2)

ie_selection.patch (7.1 KB) - added by Jared Jurkiewicz 10 years ago.
Fix for selection restore issue with dijit.Editor.
9987.patch (635 bytes) - added by Douglas Hays 10 years ago.
possible fix to restore selection for IE only

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by Jared Jurkiewicz

Far as I can tell, this didn't work in 1.3.2, either.

comment:2 Changed 10 years ago by Jared Jurkiewicz

Correction, it does work in 1.3.2.

comment:3 Changed 10 years ago by Jared Jurkiewicz

Cc: Douglas Hays added

The cause is due to a change made by DougHays?. He removed the focus over-ride in dijit.Editor, which was calling restoreSelection at the proper time. Need to understand why he removed it.

Doug?

Changed 10 years ago by Jared Jurkiewicz

Attachment: ie_selection.patch added

Fix for selection restore issue with dijit.Editor.

comment:4 Changed 10 years ago by Jared Jurkiewicz

Doug states it was removed due to: http://bugs.dojotoolkit.org/ticket/9558

Seems like breaking insert is worse than tab being a little funny.

Bill?

Changed 10 years ago by Douglas Hays

Attachment: 9987.patch added

possible fix to restore selection for IE only

comment:5 Changed 10 years ago by Jared Jurkiewicz

Doug:

Patch doesn't fix it right. Still breaks things related to the LinkDialog?.

comment:6 Changed 10 years ago by Jared Jurkiewicz

Milestone: tbd1.4
Owner: changed from bill to Douglas Hays

comment:7 Changed 10 years ago by Jared Jurkiewicz

Doug's fix does work. The problem I was seeing is a weird doh.robot timing/test setup issue, not an issue with Doug's fix.

So, committing fix.

comment:8 Changed 10 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [20300]) Fixing selection issue with IE. fixes #9987

comment:9 Changed 10 years ago by Jared Jurkiewicz

(In [20303]) Don't need the call to _restoreSelection now refs #9987

Note: See TracTickets for help on using tickets.