Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9961 closed defect (fixed)

'formatblock' in FF/Win sometimes throws exception

Reported by: stpiker Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.4
Component: Editor Version: 1.3.0
Keywords: formatblock editor Cc:
Blocked By: Blocking:

Description

Executing the formatblock command on empty lines (to set styling before typing) can throw "0x80004005(NS_ERROR_FAILURE)" exceptions for formats h2 & h3.

This bug was noticed w/ FF 3.0.14 on Windows XP/sp3. It does not occur w/ IE 8/Win or FF3/Mac.

To reproduce:

  • open .../dijit/tests/test_Editor.html
  • go to the "optional toolbar buttons" section
  • before entering text, select format "Subheading" (h2) or "Sub-subheading" (h3)
  • start entering text, you'll notice no formatting is applied and the Format selection goes away in the dropdown.

Change History (7)

comment:1 Changed 10 years ago by dante

Milestone: tbdfuture
Owner: set to Jared Jurkiewicz

comment:2 Changed 10 years ago by bill

Owner: Jared Jurkiewicz deleted

comment:3 Changed 10 years ago by Jared Jurkiewicz

Owner: set to Jared Jurkiewicz

comment:4 Changed 10 years ago by Jared Jurkiewicz

I believe this will be fixed by my async fixes in the other ticket I'm working on: #9377, as I cannot reproduce it on the current code.

comment:5 Changed 10 years ago by Jared Jurkiewicz

I think this is fixed by #9377. Reopen if you still see it.

comment:6 Changed 10 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

comment:7 Changed 10 years ago by Jared Jurkiewicz

Milestone: future1.4
Note: See TracTickets for help on using tickets.