Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9946 closed defect (fixed)

dojox.widget.Standby: behaviour not idea when target == body

Reported by: lipik Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.4
Component: DojoX Widgets Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

If dojox.widget.Standby is created with target=dojo.doc.body (or documentElement), the behaviour should change as follows:

  1. use the viewport as the sizing box, instead of body's bounding box - else the image gets positioned out of view if body's height/width is much larger than the viewport.
  1. disable scrolling while the widget is shown. Definitely when target is body, but maybe in other cases as well.

Thanks

Attachments (1)

Standby.patch (23.6 KB) - added by Jared Jurkiewicz 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by dante

Owner: changed from dante to Jared Jurkiewicz

comment:2 Changed 10 years ago by Jared Jurkiewicz

I honestly never intended this to overlay body itself, it was intended for sub-nodes.

Making the noted changes will actually add significant code to Standby, as I had to do similar to the editor fullscreen plugin. Disabling scrollers varies from IE to others, alas, and even quirks mode.

I need to think on if I want to support such uage, given the impact to code (from what I learned from the editor FullScreen?).

comment:3 Changed 10 years ago by Jared Jurkiewicz

I did a quick prototype and it actually wasn't that bad to make it work on body too (as you suggested via viewport). Need to do more testing, but will probably commit it in

Changed 10 years ago by Jared Jurkiewicz

Attachment: Standby.patch added

comment:4 Changed 10 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [20250]) Improving support for overlaying body. fixes #9946

comment:5 Changed 10 years ago by bill

Milestone: tbd1.4
Note: See TracTickets for help on using tickets.