Opened 10 years ago

Closed 10 years ago

#9930 closed defect (fixed)

[regression] Problematic dijit.Editor cursor placement on click in Webkit

Reported by: chaitanya Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.4
Component: Dijit Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

Issue with dijit.Editor: if I click on an area in the editor below the last line of text (the mouse pointer doesn't change into a cursor icon over this region, but its still the editing area), instead of positioning the cursor at the end of the text, the cursor is positioned at the beginning.

This is unexpected behaviour and it occurs in Webkit based browsers (Safari/Chrome?). It works correctly on Firefox 3.5 and IE 6.

This is confirmed on both dojo release 1.3.1 and trunk.

Attachments (1)

editorStyleWebkit.patch (504 bytes) - added by Jared Jurkiewicz 10 years ago.
I think this patch fixes it. Can you try it in your environment?

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by chaitanya

If I do this, the issue is fixed in Chrome, but not in Safari:

      var editor = new dijit.Editor({
          plugins: ['bold', 'italic'],
          height: "300px"
      }, "editor");
      var iframeDocument = editor.iframe.contentDocument;
      iframeDocument.documentElement.style.height = "100%";
      iframeDocument.body.style.height = "100%";

Changed 10 years ago by Jared Jurkiewicz

Attachment: editorStyleWebkit.patch added

I think this patch fixes it. Can you try it in your environment?

comment:2 Changed 10 years ago by chaitanya

Yes, this seems to work in both Safari 4 and Chrome 3 on Windows.

comment:3 Changed 10 years ago by Jared Jurkiewicz

Owner: set to bill

Bill,

Any problems with this?

comment:4 Changed 10 years ago by bill

Milestone: tbd1.4
Owner: changed from bill to Jared Jurkiewicz

Looks good to me, go for it.

comment:5 Changed 10 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [20198]) fixing Webkit issue. \!strict fixes #9930

comment:6 Changed 10 years ago by haysmark

Priority: normalhigh
Resolution: fixed
Status: closedreopened
Summary: Problematic dijit.Editor cursor placement on click in Webkit[regression] Problematic dijit.Editor cursor placement on click in Webkit

In [20198] auto-expanding Editors in FF3 do not actually expand anymore. Safari still seems ok.

comment:7 Changed 10 years ago by Jared Jurkiewicz

Resolution: fixed
Status: reopenedclosed

(In [20671]) Adding in fix + testcase for auto-expanding editor. Subclassed the original 9930 fix to just webkit. \!strict fixes #9930

Note: See TracTickets for help on using tickets.