Opened 10 years ago

Closed 10 years ago

#9923 closed defect (worksforme)

ComboButton: Keyboard focus does not go to the arrow portion in IE8

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: high Milestone: 1.4
Component: Accessibility Version: 1.3.2
Keywords: Cc: Nathan Toone
Blocked By: Blocking:

Description

Load dijit/tests/form/test_Button.html. Press tab to move focus from button to button. Notice that with focus on the "Create" portion of the first comboButton, pressing tab again takes you back to the top of the page. Focus should go to the arrow portion of that button. I tested with compatibility mode on and off in IE 8 with the same results.

Works correctly in FF 3.5 (Win), Safari 4.03 (Mac), Firefox 3.0.13 (Mac), IE 6

Change History (5)

comment:1 Changed 10 years ago by Becky Gibson

Milestone: tbd1.4

comment:2 Changed 10 years ago by Becky Gibson

There is also a problem with the menubar in IE8 - Tab to "File" in the menubar, press enter and the drop down menu opens and immediately closes. Works properly in Firefox. Also, in IE 8 Focus does not go the the "Drama" menu when I press tab and cycle through the page.

comment:3 Changed 10 years ago by Becky Gibson

This might be a problem with my machine - although I have no clue what. But I have this problem in older builds as well in IE8 - can someone please verify? Thanks.

comment:4 Changed 10 years ago by bill

I can't reproduce any of these issues. I tested these things on IE8 and they are working fine for me:

  1. tabbing through the "Create" ComboButton in test_Button.html
  2. opening the File menu via ENTER key
  3. tabbing to the drama menu

comment:5 Changed 10 years ago by Becky Gibson

Resolution: worksforme
Status: newclosed

Was a security setting in my version of IE 8 - stupid IE! Sorry for the firedrill - it works fine so am closing.

Note: See TracTickets for help on using tickets.