Opened 10 years ago

Closed 9 years ago

#9911 closed defect (duplicate)

[Latest trunk / DataGrid / Editable Feature / IE7,8] - Row flashing before entering edit mode

Reported by: Evan Owned by:
Priority: high Milestone: 1.7
Component: DojoX Grid Version: 1.3.2
Keywords: ibm oci grid Cc: toonetown@…, drschwar@…, hwcdl@…, hongg@…
Blocked By: Blocking:

Description

In IE7, when use double clicks in any cell, the whole set of data records in each cell flashes with the highlight - blue background, white text and then goes away and enables the embedded form widget. This issue might not happen for the 1st db click after page get loaded.

Steps to reproduce the issue:

  1. Open test case - http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/grid/tests/test_edit_dijit.html
  2. Double click in any cell to see the issue

More details please see the attached pic (gird_ie7_edit_flash_issue.html)

Attachments (1)

gird_ie7_edit_flash_issue.html.gif (154.0 KB) - added by Evan 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by bill

Component: GeneralDojoX Grid
Owner: changed from anonymous to Bryan Forbes

Changed 10 years ago by Evan

comment:2 Changed 10 years ago by Nathan Toone

Milestone: tbd1.5
Owner: changed from Bryan Forbes to Nathan Toone

It looks like the text is getting selected - even though we are calling dojo.setSelectable(false) on the domNode. Not sure why that is...

comment:3 Changed 10 years ago by tikiboy

We have found that in IE the entire column of editable cells becomes un-editable after editing one cell, yet are still selectable. We found a solution by making the following change to dojox/grid/cells/_base.js

Index: _base.js =================================================================== --- _base.js (revision 21641) +++ _base.js (working copy) @@ -247,7 +247,9 @@

called when editing is completed to clean up editor inRowIndex: int grid row index

  • dojo.setSelectable(this.grid.domNode, false);

+ if (!dojo.isIE){ + dojo.setSelectable(this.grid.domNode, false); + }

this.cancelFormatNode();

}, public

I just mention it here because it seems like it may be related. Hope this helps.

comment:4 Changed 10 years ago by tikiboy

Oops, formatting did not work so good on that. Lets try again

Index: _base.js
===================================================================
--- _base.js	(revision 21641)
+++ _base.js	(working copy)
@@ -247,7 +247,9 @@
 			//	called when editing is completed to clean up editor
 			// inRowIndex: int
 			// grid row index
-			dojo.setSelectable(this.grid.domNode, false);
+			if (!dojo.isIE){
+				dojo.setSelectable(this.grid.domNode, false);
+			}
 			this.cancelFormatNode();
 		},
 		//public

comment:5 Changed 10 years ago by Nathan Toone

Milestone: 1.5future
Owner: Nathan Toone deleted

Moving my tickets to future, as I am not currently working on them.

comment:6 Changed 9 years ago by evan

Milestone: future1.7
Resolution: duplicate
Status: newclosed

duplicate with #12880, already fixed with [24707]

Note: See TracTickets for help on using tickets.