Opened 10 years ago

Closed 10 years ago

#9908 closed defect (fixed)

"already called" error on chrome

Reported by: bill Owned by: bill
Priority: high Milestone: 1.4
Component: Editor Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

Loading test_Editor.html (or anything w/an editor) causes an "already called" error.

The problem is this code:

if(dojo.isWebKit){ // Safari seems to always append iframe with src=about:blank
	setTimeout(function(){ifr.setAttribute('src', s);},0);
}

That causes the iframe to load twice, calling onLoad() twice, which then calls onLoadDeferred.callback() (twice).

Change History (1)

comment:1 Changed 10 years ago by bill

Resolution: fixed
Status: newclosed

(In [20123]) Remove overzealous dojo.isSafari --> dojo.isWebkit conversion, fixes #9908 !strict.

Note: See TracTickets for help on using tickets.