Opened 10 years ago

Closed 8 years ago

#9901 closed defect (fixed)

Editor back/forward code causes webkit warnings

Reported by: bill Owned by:
Priority: high Milestone: 1.7
Component: Editor Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

Loading the editor in Chrome v3 causes error messages:

Unmatched </head> encountered.  Ignoring tag.
Extra <body> encountered  Migrating attributes back to original <body> element and ignoring the tag.

The problem is from the stabile state-saving code, assumedly this line:

dojo.body().appendChild(savetextarea);

It executes while scripts are still loading, so <head> hasn't finished yet.

Not sure of the effects of this problem.

Change History (7)

comment:1 Changed 10 years ago by bill

Milestone: tbd1.5

comment:2 Changed 9 years ago by Adam Peller

Milestone: 1.51.6

comment:3 Changed 9 years ago by stewartlord

This issue affects Safari as well (not surprisingly).

The problem is that the creation of the hidden textarea happens outside of the dojo.declare block. Is there any reason why this can't be postponed until some stage of the dijit lifecycle? Doing work outside of the declare like this seems rather offensive.

comment:4 Changed 9 years ago by bill

Summary: Editor back/forward code causes chrome warningsEditor back/forward code causes webkit warnings

I think it needs to happen early (before page load finishes) or otherwise the value won't be preserved on back/forward button. That's the idea anyway, that the textarea serializes the editor contents and when the user presses back then forward, when the page reloads (due to the forward button) the browser restores the contents of the <textarea>, which Editor uses to restore it's own contents.

It's likely though that none of that code is actually working.

comment:5 Changed 9 years ago by globex

Any way we can increase the priority on this one? It's sort of a showstopper since if you're using dojo.Editor in your build it makes the entire Dojo build fail in Safari and Chrome making your website unusable.

comment:6 Changed 9 years ago by Jared Jurkiewicz

Milestone: 1.6future

comment:7 Changed 8 years ago by Jared Jurkiewicz

Milestone: future1.7
Resolution: fixed
Status: newclosed

I believe this was resolved in 1.7, with the cleanup of how editor saved state between pages.

Note: See TracTickets for help on using tickets.