Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9892 closed defect (duplicate)

A11Y Test failure for dijit.Editor in Firefox 2, Firefox 3.

Reported by: Jared Jurkiewicz Owned by: bill
Priority: high Milestone: 1.4
Component: Editor Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

This test fails in FireFox? 2 and FireFox? 3.0, it passes in IE 7 and Chrome

File: dijit/tests/editor/robot/Editor_a11y.html

Reported failure: GROUP "keyboard shortcuts" has 1 test to runbootstrap.js (line 788) _AssertFailure: file:///X:/dojo/trunk/dojo/_base/_loader/bootstrap.js:572 doh._AssertFailure: assertEqual() failed: expected hello <b>bold</b> and <i>exciting</i> new world. but got hello <b>bold</b> and <i>exciting</i> new world.<p>This instance is created from a div directly with default toolbar and plugins</p> The following HTML should appear as source: &lt;INPUT TYPE=&quot;IMAGE&quot; SRC=&quot;javascript:alert('no scripting attacks')&quot;&gt; bootstrap.js (line 788) doh._AssertFailurebootstrap.js (line 788) ERROR IN: (function () {var d = new doh.Deferred;dijit.scrollIntoView(editor1.domNode);doh.robot.sequence(function () {editor1.focus();}, 500);doh.robot.keyPress("a", 500, metaKey);doh.robot.typeKeys("hello ", 500);doh.robot.keyPress("b", 500, metaKey);doh.robot.typeKeys("bold", 500);doh.robot.keyPress("b", 500, metaKey);doh.robot.typeKeys(" and ", 500);doh.robot.keyPress("i", 500, metaKey);doh.robot.typeKeys("exciting", 500);doh.robot.keyPress("i", 500, metaKey);doh.robot.typeKeys(" new world.", 500);doh.robot.sequence(d.getTestCallback(function () {var val = normalize(editor1.attr("value"));doh.is("hello <b>bold</b> and <i>exciting</i> new world.", val);}), 1500);return d;})bootstrap.js (line 788) Total time for GROUP " keyboard shortcuts " is 0 ms

It looks like selection is not clearing contents when typing begins. This test used to pass, so I can only assume it has to do with some rework Bill did recently regarding space and such and FireFox? in the editor. So, assigning to him to look at.

This occurs on trunk revision: 14799

Change History (4)

comment:1 Changed 10 years ago by Jared Jurkiewicz

I have a feeling this is timing related. Such as the selection isn't complete before typing begins or somesuch and it gets missed so the replace doesn't happen.

comment:2 Changed 10 years ago by bill

Milestone: tbd1.4
Status: newassigned

Oops, thanks for catching that. Looks like I broke it starting with [20100] (I assume the trunk revision you listed above was a typo.) Actually I can reproduce it by hand, tabbing into the second editor, typing ctrl-A then "hello".

comment:3 Changed 10 years ago by bill

Resolution: duplicate
Status: assignedclosed

Actually I'll just mark this as a dup and make the fix referencing #9151.

comment:4 Changed 10 years ago by bill

(In [20108]) Fix regression from [20100] where tabbing to second editor, selecting text via ctrl-a, then typing something doesn't erase selected text. Refs #9151, #9892 !strict.

Note: See TracTickets for help on using tickets.