Opened 10 years ago

Closed 8 years ago

#9844 closed defect (invalid)

dojox.grid.DataGrid dijit widget calls setValue to the store with invalid values

Reported by: Betelgeuse Owned by: Betelgeuse
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

I have a DataGrid? with a NumberSpinner? in it:

    {
      field: "quantity",
      name: "Quantity",
      width: "auto",
      type: dojox.grid.cells._Widget,
      widgetClass: dijit.form.NumberSpinner,
      constraint: { min: 1, max: 1000}
    }

Browser Info

The browser I am using is FF 3.5.2 on Windows Vista

Steps to reproduce

  1. Clear the text value in the spinner
  2. Press enter in keyboard
  3. setValue is called in the store with NaN as value

Expected results

The value is invalid and the grid should give an error message to user instead of setting the value to NaN

Change History (2)

comment:1 Changed 8 years ago by ben hockey

Owner: changed from Bryan Forbes to Betelgeuse
Status: newpending

Betelgeuse, if this issue is still valid could you attach a test case? if there is no response within 14 days, this issue will automatically be closed.

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.