Opened 10 years ago

Closed 7 years ago

Last modified 7 years ago

#9841 closed defect (fixed)

[regression] DTL doh test failure in test_tag_ifequal on FF3.5/mac

Reported by: bill Owned by: Neil Roberts
Priority: low Milestone: 1.7
Component: DojoX DTL Version: 1.3.2
Keywords: dohfail Cc:
Blocked By: Blocking:

Description

On FF3.5/mac on trunk, the DTL tests are failing. They are working in dojo 1.3, and also they are working on Safari 4.0. The failure is:

     _AssertFailure: doh._AssertFailure: assertEqual() failed:
 	expected
		<div><ul><li><span>apple</span><br/><p>red</p></li><li><label>Name: <input name="name" value="banana"/></label><br/><label>Color: <textarea name="color">yellow</textarea></label></li><li><span>pear</span><br/><p>green</p></li><li><span>kiwi</span><br/><p>brown</p></li></ul></div>
	but got
		<div><ul><li><span>apple</span><br/><p>red</p></li><li><label>Name: <input name="name" value="{{ item.name }}"/></label><br/><label>Color: <textarea name="color">yellow</textarea></label></li><li><span>pear</span><br/><p>green</p></li><li><span>kiwi</span><br/><p>brown</p></li></ul></div>

: ...
     ERROR IN:
 		 function test_tag_ifequal(t) {
...
 FAILED test: test_tag_ifequal 18 ms

It's printing value="{{ item.name }}" rather than the expected value="banana"

Change History (9)

comment:1 Changed 10 years ago by bill

Summary: [regression] DTL doh test failure on FF3.5/mac[regression] DTL doh test failure in test_tag_ifequal on FF3.5/mac

comment:2 Changed 9 years ago by Adam Peller

Milestone: tbd1.4

comment:3 Changed 9 years ago by Adam Peller

Keywords: 14open added

moving 1.4 open tickets to 1.5

comment:4 Changed 9 years ago by ID

Actually domTemplated is not handling <input> tags properly because even this simple test will fail:

var template = new dd.DomTemplate('<input type="text" name="name" value="{{ test_value }}" />');
var context = new dd.Context({ test_value: "banana" });
t.is('<input type="text" name="name" value="banana"/>', dd.tests.dom.util.render(template, context));

From this result:

expected
	<input type="text" name="name" value="banana"/>
but got
	<input name="name" value="{{ test_value }}"/>

We can see that {{ test_value }} didn't get parsed and the type="text" attribute disappeared

comment:5 Changed 9 years ago by bill

Milestone: 1.51.6

1.5 is released, moving remaining tickets to 1.6

comment:6 Changed 8 years ago by bill

Milestone: 1.6future

(sadly) punting seemingly abandoned ticket and meta tickets to future

comment:7 Changed 8 years ago by bill

Keywords: dohfail added; 14open removed

comment:8 Changed 7 years ago by ben hockey

Milestone: future1.7
Priority: highlow
Resolution: fixed
Status: newclosed

there are currently a number of other failures in dtl but there doesn't seem to be any for test_tag_ifequal in ff 11. i don't know when it was fixed (and don't care to spend time looking) so marking with milestone of 1.7

comment:9 Changed 7 years ago by bill

Agreed, it failed in 1.6 but started working in 1.7, although 1.7 has a failure in test_annoying_nesting.html. And trunk is getting a lot of failures after [27723] so I'll open a different ticket for that.

Note: See TracTickets for help on using tickets.