Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#9836 closed defect (fixed)

[regression] Textarea initialization problem on IE6

Reported by: bill Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

On IE6 loading themeTester.html I get an error in:

textarea.style.maxHeight = textarea.style.height = newH;

because newH is -8px.

themeTester.html on 1.3 is working fine so I guess this is a regression (but not sure what caused it).

Change History (3)

comment:1 Changed 10 years ago by bill

Hmm, it started happening in [19739] although not sure what one thing has to do w/another. dijit_form_Textarea_0 is getting a call to resize() although it's on a hidden tab... probably because of the setTimeout(dojo.hitch(this, "resize"), 0); in postCreate().

comment:2 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [20148]) Fixes #9836. Check for zero offsetHeight and clientHeight and estimate height accordingly.

comment:3 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.