Opened 10 years ago

Closed 10 years ago

#9835 closed defect (fixed)

[regression] RollingList blank, shows no data

Reported by: bill Owned by: Nathan Toone
Priority: high Milestone: 1.4
Component: DojoX Widgets Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

test_RollingList.html and test_FilePicker.html are blank for me, on my trunk tree, although working on my 1.3 tree. (Yes I have PHP.)

Tested on FF3.5/mac.

See also #9833.

Change History (4)

comment:1 Changed 10 years ago by bill

Description: modified (diff)
Summary: [regression] FilePicker blank, shows no files[regression] RollingList blank, shows no data

comment:2 Changed 10 years ago by bill

Milestone: tbd1.4
Owner: changed from dante to bill
Status: newassigned

The onLoadDeferred() error mentioned in #9833 started in [17524], because this.onLoadDeferred is null. And the blank problem started in [20000].

comment:3 Changed 10 years ago by bill

Owner: changed from bill to Nathan Toone
Status: assignednew

Nathan, can you handle this one? I'm not sure what this code is supposed to be doing.

The latter issue with the blank entries is because _loadCheck() has been removed from ContentPane (in favor or _onShow()), but there's another problem that RollingList's handlers for store.onNew() etc. call _loadCheck(true) when _loadCheck() itself doesn't take an argument. Seems like those handlers should be calling _doQuery() or something.

The former issue with onLoadDeferred is that RollingList.onItems() calls this._onLoadHandler() but onLoadDeferred hasn't been setup yet because _setContentAttr()/refresh()/etc. hasn't been called yet. Maybe

  1. rename _doQuery() to _load(), to override ContentPane's _load() method that fetches from a URL
  2. remove/replace _loadQuery() and calls to it with refresh(). refresh() is the function meant to reload.

comment:4 Changed 10 years ago by Nathan Toone

Resolution: fixed
Status: newclosed

(In [20210]) Fixes #9835 - make rolling list and file picker behave with all the changes that have been made to ContentPane? !strict

Note: See TracTickets for help on using tickets.