Opened 10 years ago

Closed 7 years ago

#9830 closed enhancement (invalid)

Error when creating dojo build

Reported by: Goran Miskovic Owned by: Goran Miskovic
Priority: low Milestone: future
Component: BuildTools Version: 1.1.1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by Adam Peller)

When giving more than one option to argument action there must be no space after comma. Otherwise following or similar exception (depend on ordering) will be raised:

buildscripts$ ./build.sh profileFile=$HOME/dojo_builds/custom.profile.js version=$version releaseName=$buildName copyTests="false" cssOptimize="comments" action="clean, release, intern-strings"
clean:  Deleting: ../../release/
js: uncaught JavaScript runtime exception: TypeError: Cannot find function  release.

Change History (5)

comment:1 Changed 10 years ago by Adam Peller

Description: modified (diff)
Owner: changed from alex to James Burke

confirmed in trunk

comment:2 Changed 10 years ago by Adam Peller

Component: PackageSystemBuildTools

comment:3 Changed 10 years ago by James Burke

Milestone: tbdfuture

The build system was not constructed to handle quotes in the arg parsing, but I have seen this style of arg parsing before.

comment:4 Changed 8 years ago by ben hockey

Owner: changed from James Burke to Goran Miskovic
Priority: highlow
Status: newpending

since we have a completely new build system in dojo 1.7 I'm going to set this ticket to automatically close within 14 days unless someone leaves a comment - which will prevent the ticket from being automatically closed.

comment:5 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.