Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9827 closed defect (invalid)

TextBox inside Grid does not work properly

Reported by: panf Owned by: Bryan Forbes
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.3.2
Keywords: Cc: Becky Gibson, Nathan Toone
Blocked By: Blocking:

Description (last modified by Adam Peller)

Doesn't show space typing inside textBox. And needs two clicks to accept focus. Try it at http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/grid/tests/test%5Fgrid%5Fformatters.html

I use FF 3.5

Change History (8)

comment:1 Changed 10 years ago by Adam Peller

Cc: Becky Gibson added
Keywords: a11y added

comment:2 Changed 10 years ago by Becky Gibson

Cc: Nathan Toone added

this looks like new functionality, cc'ing toonetown

comment:3 Changed 10 years ago by Nathan Toone

Keywords: a11y removed
Resolution: invalid
Status: newclosed

That is not the purpose of the text box in this test case - the purpose of this test case is just to demonstrate rendering of a widget (textbox was chosen for simplicity - but it could have been a button or any other widget).

It is also not an a11y issue...

I am closing as not a bug (invalid) - however, if it causes too much confusion or problems, then we can change the widget to be something else (like a button) or have the text box disabled.

comment:4 Changed 10 years ago by Adam Peller

I added a11y since this appeared to be a focus issue and just wanted to cc becky. So if you click on the textbox, it changes focus to the grid cell but not the widget, and a second click is required to get focus on the textbox. Is that working as intended? What about the spaces?

comment:5 Changed 10 years ago by panf

Ok, if this isn't a bug, what I should do to make it available one click focus and space typing?

comment:6 in reply to:  3 Changed 10 years ago by panf

Resolution: invalid
Status: closedreopened

Replying to toonetown:

That is not the purpose of the text box in this test case - the purpose of this test case is just to demonstrate rendering of a widget (textbox was chosen for simplicity - but it could have been a button or any other widget).

It is also not an a11y issue...

I am closing as not a bug (invalid) - however, if it causes too much confusion or problems, then we can change the widget to be something else (like a button) or have the text box disabled.

The purpose of the text box is accepting some text that is typing. In our case we can do it only after two clicks for focusing and no spaces in text. Do you seen any texts without spaces? :))

If we put button instead of text box than we will see the same. Need two clicks for pressing it.

comment:7 Changed 10 years ago by Nathan Toone

Description: modified (diff)
Resolution: invalid
Status: reopenedclosed

That is not the way to make an "editable" cell. If you want editable cells, please see the example at http://docs.dojocampus.org/dojox/grid/#editing-data

comment:8 Changed 10 years ago by Adam Peller

Description: modified (diff)

Not sure if this is related, but another user tried to use a formatter with just an INPUT and had similar focus problems.

http://stackoverflow.com/questions/1553154/unable-to-set-focus-to-textbox-in-dojo-datagrid

the first question was here

http://stackoverflow.com/questions/1366963/textbox-inside-grid-does-not-work-properly/1374846#1374846

Note: See TracTickets for help on using tickets.