Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#9825 closed enhancement (fixed)

DataPresentation widget

Reported by: deandwill Owned by: Eugene Lazutkin
Priority: high Milestone: 1.4
Component: Charting Version: 1.3.2
Keywords: Cc: Adam Peller, Mike Wilcox
Blocked By: Blocking:

Description (last modified by Adam Peller)

A widget that connects to a data store in a simple manner, and also provides some additional convenience mechanisms for connecting to common data sources without needing to explicitly construct a Dojo data store. The widget can then present the data in several forms: as a graphical chart, as a tabular grid, or as display panels presenting meta-data (title, creation information, etc) from the data. The widget can also create and manage several of these forms in one simple construction.

Attachments (4)

DataPresentation-090827.patch (24.4 KB) - added by Adam Peller 10 years ago.
Initial implementation, from Dave Clark (IBM)
DataPresentation.js (24.3 KB) - added by Mike Wilcox 10 years ago.
Data Presentation JS file
DataPresentation.html (7.4 KB) - added by Mike Wilcox 10 years ago.
Test for Data Presentation widget
DataPresentation-091005.patch (32.9 KB) - added by Adam Peller 10 years ago.
latest patch from Dave Clark, with a test file

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Adam Peller

Component: GeneralCharting
Description: modified (diff)
Milestone: tbd1.4
Owner: changed from anonymous to Eugene Lazutkin

comment:2 Changed 10 years ago by Adam Peller

Cc: Mike Wilcox added

patch needs improvement on style guide conformance, e.g. if (...)

Changed 10 years ago by Adam Peller

Initial implementation, from Dave Clark (IBM)

Changed 10 years ago by Mike Wilcox

Attachment: DataPresentation.js added

Data Presentation JS file

Changed 10 years ago by Mike Wilcox

Attachment: DataPresentation.html added

Test for Data Presentation widget

comment:3 Changed 10 years ago by Eugene Lazutkin

Milestone: 1.4future
Status: newassigned

comment:4 Changed 10 years ago by Adam Peller

Milestone: future1.4

A new patch should land today. The team is planning on getting in experimental code for 1.4

Changed 10 years ago by Adam Peller

latest patch from Dave Clark, with a test file

comment:5 Changed 10 years ago by Adam Peller

Resolution: fixed
Status: assignedclosed

(In [20410]) Initial drop of dojox.widget.DataPresentation? from Dave Clark (IBM, CCLA) Fixes #9825 !strict

comment:6 Changed 8 years ago by cjolif

#8981 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.