Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#9782 closed defect (fixed)

IE: regression in ComboBox after applying [19927]

Reported by: Douglas Hays Owned by: bill
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

Using revision [19927] or later, run dijit/tests/form/test_ComboBox.html using IE.
Click to focus the 2nd combobox on the page (8pt font).
Now click the arrow button and the drop down should appear, but instead an exception is thrown:
[ Error: xhr cancelled ]
dijit.form.ComboBox?: [object Error]
The 2nd click of the down arrow does open the popup.

Change History (3)

comment:1 Changed 10 years ago by bill

Status: newassigned

Ugh, OK, thanks.

The drop down is showing up momentarily but the problem is that clicking the drop down arrow (which is an unfocusable <div>) is making focus.js think that the ComboBox has lost focus.

Clicking the arrow causes an ondeactivate event on the <input>, and onactivate on the <div>, but the focus code is ignoring the latter since the <div> isn't focusable.

comment:2 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [19966]) Try again to get focus on IE working properly. Clicking a non-focusable node (including <body>) shouldn't be considered a focus, but it should at least be considered a node touch.

Refs #9735, fixes #9782 !strict.

comment:3 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.