Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#9769 closed defect (invalid)

DateTextBox stops allowing manual input after DIalog has been opened and closed.

Reported by: nixj14 Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

I've run into an issue with the DateTextBox? and the ability to type the date in manually vs using the calendar popup after a Dialog box has been opened and closed on a page. The attached file/test case was reproducable in FF3. I did notice that IE8 did not experience the same issue.

Steps to reproduce: 1) Start by making sure that you have the ability to edit the DateTextBox? by manually typing in the date in the input text field. 2) Open up a Dialog. 3) Close the Dialog. 4) Go back to the DateTextBox? field and try to manually edit.

Attachments (2)

DateTest.html (1.9 KB) - added by nixj14 10 years ago.
DateTextBox? with Dialog test
DateTestBill.html (1.8 KB) - added by bill 10 years ago.
test case against dijit.Dialog, working for me on FF3.5/mac

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by nixj14

Attachment: DateTest.html added

DateTextBox? with Dialog test

comment:1 Changed 10 years ago by nixj14

I forgot to mention that I'm using mainstream version of dojo straight from the SVN repository.

comment:2 Changed 10 years ago by bill

Resolution: invalid
Status: newclosed

It doesn't seem like you are, because you are using a widget called StackableModalDialog and there's no such widget in dijit. When I modified your test case to have the proper dojo.require() calls and removed the layer references, it worked fine for me. I'll attach my test case.

If you get a problem using standard dialog please reopen.

Changed 10 years ago by bill

Attachment: DateTestBill.html added

test case against dijit.Dialog, working for me on FF3.5/mac

comment:3 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.