Opened 10 years ago

Closed 10 years ago

#9768 closed defect (duplicate)

Grid horizontal scrollbar does not properly respond

Reported by: csmith Owned by: Nathan Toone
Priority: high Milestone: 1.5
Component: DojoX Grid Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

Hi all,

In WinXP Firefox 2.0.14/3.0.6, I have a Grid that is scrollable both horizontally and vertically. I am using 1.3.1 w/patch.

Upon first loading, the grid is display with a vertical and horizontal scroll bars are displayed. The horizontal scroll bar is aligned/default to the left of the grid. When I click in the blank space slightly right of the horizontal scroll bar to shift to the right, nothing happens. In other words, the horizontal scroll bar snaps back to the left of the grid. The vertical scrolling of the grid functions as expected when clicking in the blank space.

Problems appears to be somewhere within the _FocusManager.js If I changed the foucsHeader function line of code (near line 480):

else if (!this.colHeadFocusIdx) {

to

else if (this.colHeadFocusIdx)

and comment out the focusHeader function line of code (near line 499):

this.findAnFocusGridCell()

Somewhat respond as expected. Meaning, with these changes, requires clicking twice in the blank space to the horizontal scroll bar. The scroll bar moves to right. I should be able click one time to the right of the horizontal scroll bar.

Has anyone else experience this or found a fix/workaround?

Thanks, csmith

Change History (3)

comment:1 Changed 10 years ago by Adam Peller

Component: GeneralDojoX Grid
Owner: changed from anonymous to Bryan Forbes

comment:2 Changed 10 years ago by Nathan Toone

Milestone: tbd1.5
Owner: changed from Bryan Forbes to Nathan Toone

I believe the may be related/the same as #9722

comment:3 Changed 10 years ago by Nathan Toone

Resolution: duplicate
Status: newclosed

Duplicate of #9756

Note: See TracTickets for help on using tickets.