Opened 10 years ago

Closed 10 years ago

#9751 closed defect (duplicate)

[PATCH][CLA] missing the bundleMap reference in loader_xd

Reported by: youngho Owned by: James Burke
Priority: high Milestone: tbd
Component: Core Version: 1.3.2
Keywords: xdRequire Cc:
Blocked By: Blocking:

Description

There is a missing the first match bundle resources reference in loader_xd.

Attachments (1)

loader_xd.patch (656 bytes) - added by youngho 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by youngho

Attachment: loader_xd.patch added

comment:1 Changed 10 years ago by James Burke

Do you have a test case that demonstrates how the code fails? This issue has been in the code for many moons now, and I assumed it was a dead code path -- poor coding on my part for a situation that does not ever get triggered. However if you are seeing a failure, that would be good to know and have a test case to avoid future regressions.

comment:2 Changed 10 years ago by youngho

Hello jburke,

So far I didn't split out the test case from my situation.

I have a trouble with xd loading issue which suspects few reasons combined including my custom build profile.

But this patch didn't work as expect so please close this ticket. I will attach the test case when I get it soon and reopen it.

comment:3 Changed 10 years ago by James Burke

Resolution: invalid
Status: newclosed

OK. I recently fixed two loader-related issues, you might see if those changesets help your situation: #9727 and #9659

comment:4 Changed 10 years ago by Adam Peller

Resolution: invalid
Status: closedreopened

Hi James.

I've got a product team telling me they've hit this line of code, and I'm hoping I can get a test case. Blame points me at [16890], but it looks like this bad reference has been around over 2 years?! I'm a bit surprised that this code could have been in the build for so long and not come up sooner, but it does appear to be a reference to the variable before it's defined. Can we just move the bundleMap declaration out of the if-else?

comment:5 Changed 10 years ago by James Burke

Yeah, it has been around for a while, that was why I was interested in a test case, to see how the code is triggered.

But if it is not possible to isolate the failure case as a stand-alone test, if moving out the bundleMap declaration works, that would be interesting to know. I am still a bit concerned though that for normal operation, I do not think that pathway is followed. I would suspect another bug if for some reason it is followed.

comment:6 Changed 10 years ago by Adam Peller

see #9816

comment:7 Changed 10 years ago by Adam Peller

Owner: changed from anonymous to James Burke
Status: reopenednew

comment:8 Changed 10 years ago by Adam Peller

Resolution: duplicate
Status: newclosed

closing as dup

Note: See TracTickets for help on using tickets.