Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#9737 closed defect (invalid)

dojo.gfx breaks in IE on complex data

Reported by: Felix Bünemann Owned by: Eugene Lazutkin
Priority: high Milestone: 1.5
Component: DojoX GFX Version: 1.3.2
Keywords: dojo.gfx svg json ie Cc:
Blocked By: Blocking:

Description

I've written a tool that converts SVG to JSON in the format required by dojo.gfx. The generated code works fine in Safari 4, Firefox 3.5 and Opera 9.6, but breaks on IE 6-8.

The errors seem to indicate that this.rawNode is undefined and happens eg. with rect objects (if you selectively enable layers you can see that some throw script errors and others not, eg. box1 throws errors).

I tested with the latest stable release source distribution of dojo 1.3.2 using the dojox/dojo.gfx/demos/inspector.html tool to load and render the JSON data.

I've attached a rather simple sample JSON file for verification.

Best Regards,

Felix Buenemann

Attachments (2)

testsvg1.json (3.2 KB) - added by Felix Bünemann 10 years ago.
Sample JSON file that triggers the bug
testsvg1.svg (1.7 KB) - added by Felix Bünemann 10 years ago.
SVG source for sample JSON file

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Felix Bünemann

Attachment: testsvg1.json added

Sample JSON file that triggers the bug

Changed 10 years ago by Felix Bünemann

Attachment: testsvg1.svg added

SVG source for sample JSON file

comment:1 Changed 10 years ago by Eugene Lazutkin

Component: GeneralDojoX GFX
Milestone: tbdfuture
Owner: changed from anonymous to Eugene Lazutkin
Status: newassigned

Sigh. It looks like the infamous timing bug has reared its head again. Hopefully we can find a workaround.

comment:2 Changed 9 years ago by liyang

This is not a bug but a misunderstanding of the JSON format GFX requires. GFX expects numbers in number syntax, which means "y" : "19.435" is not correct, and "y" : 19.435 is correct. And that's exactly why the given JSON sample does not work in IE. After changing the numbers to number syntax, the sample works well. I verified on the trunk.

Suggest to close this ticket.

comment:3 Changed 9 years ago by Eugene Lazutkin

Resolution: invalid
Status: assignedclosed

comment:4 Changed 9 years ago by Eugene Lazutkin

Milestone: future1.5
Note: See TracTickets for help on using tickets.