Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#9729 closed defect (fixed)

dojo 1.3.2 dijit.form.NumberTextBox

Reported by: Aleksey Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

CURRENT: format: function(/*Number*/ value, /*dojo.number.FormatOptions*/ constraints){ ...............................

if(this.editOptions && this._focused){

constraints = dojo.mixin(dojo.mixin({}, this.editOptions), constraints);

}

..................................

}

MUST BE: ............................... dojo.mixin(dojo.mixin({}, constraints), this.editOptions); ...............................

because pattern for 'edit' must replace pattern for 'view'. I use pattern "#,##0.######", and on focus it's not changes.

Change History (4)

comment:1 Changed 10 years ago by bill

I'm not sure I understand what the problem is, can you attach a test case?

comment:2 Changed 10 years ago by Douglas Hays

Milestone: tbd1.4
Owner: set to Douglas Hays

comment:3 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [19941]) Fixes #9671, #9729. Changed constraints mixin to add editOptions last. Added test for editOptions to test_validate.html. Add specialized isValid to NumberTextBox? to return the correct isValid when editing and the displayed value has not yet been formatted. This happens when ENTER is pressed inside a Form widget. Fixed an automated test oops.

comment:4 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.