Opened 10 years ago

Closed 6 years ago

#9722 closed defect (patchwelcome)

can't scroll grid in grid_hideHdr test on FF

Reported by: dtynan Owned by:
Priority: high Milestone: future
Component: DojoX Grid Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

Using the latest nightly build, you cannot scroll the grid's contents using the test at http://archive.dojotoolkit.org/nightly/checkout/dojox/grid/tests/test_data_grid_hideHdr.html when running in FF 3.0.13 (it does work in IE8)

If you try to scroll down by clicking the down arrow on the scrollbar or clicking in the scrollbar somewhere, it will slightly scroll down & immediately scroll back to the top. This happens when you click once or a few times ... note that you can drag the scrollbar down and get it to move without jumping back to the top.

Thanks, Dylan

Change History (7)

comment:1 Changed 10 years ago by dtynan

Well I can't figure out how to up the severity of this (may not have authority), but I think it should be.

Even though it only affects grid's with a hidden header, the problem is pretty significant. I've now tested with several more browsers:

Opera -- same problem as FF. Safari & Chrome -- lets you scroll down one or two positions & then just stops.

After messing around with this some more, I determined that if you get the selection outline box and use the keyboard to scroll that down a few rows, you are then able to use the mouse & click the down arrow to scroll down --- but only to the point where that keyboard-based outline box is. Anyway, I don't know how useful that is, but basically the problem is a huge problem for anyone using grids with a hidden header. I think this needs to be fixed in 1.4, if possible.

Thanks, Dylan Tynan

comment:2 Changed 10 years ago by Nathan Toone

Milestone: tbd1.5
Owner: changed from Bryan Forbes to Nathan Toone

This looks like it's some kind of focus issue. I can look at it - but probably not in the 1.4 timeframe.

comment:3 Changed 10 years ago by Nathan Toone

Resolution: duplicate
Status: newclosed

Dupe of #9756

comment:4 Changed 9 years ago by robwaite

Resolution: duplicate
Status: closedreopened

Is this definitely a dup of #9756? I get very similar behavior in 1.4 and this is vertical scrolling... the other is horizontal. As mentioned in the other ticket... I got it to go away by commenting out lines in the focusmanager.

comment:5 Changed 9 years ago by Nathan Toone

Milestone: 1.5future
Owner: Nathan Toone deleted

Moving my tickets to future, as I am not currently working on them.

comment:6 Changed 6 years ago by bill

DojoX Grid and EnhancedGrid are deprecated in favor of dgrid and gridx.

You should upgrade your code to use one of those two grids.

We will consider patches to the old DojoX Grid code though.

comment:7 Changed 6 years ago by bill

Resolution: patchwelcome
Status: reopenedclosed
Note: See TracTickets for help on using tickets.