Opened 10 years ago

Closed 7 years ago

#9711 closed defect (invalid)

Can not make custom build.

Reported by: virsir Owned by: virsir
Priority: low Milestone: future
Component: BuildTools Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

Hello, i am using the newest svn head's dojo and try to make a custom build.
mini=true loader=xdomain cssOptimize=comments action=release optimize=shrinksafe

But I get below error:

js: "../../dojo/./_base/json.js", line 78: exception from uncaught JavaScript throw: Error: Can't serialize DOM nodes

Attachments (1)

project.zip (742 bytes) - added by virsir 10 years ago.
TestProject?

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by Adam Peller

Component: PackageSystemBuildTools
Owner: changed from alex to James Burke

comment:2 Changed 10 years ago by James Burke

Resolution: invalid
Status: newclosed

I did a build using the following command using trunk code, revision [19842]:

./build.sh profile=standard mini=true loader=xdomain cssOptimize=comments action=release optimize=shrinksafe

And there were no errors while doing the build. Maybe it was your specific build profile? In the above command I was using the standard build profile.

Feel free to reopen if there is more information. The error sounds very weird, it sounds like an error from running dojo in a web page, since the build does not deal with DOM nodes.

comment:3 Changed 10 years ago by virsir

The problem occurred while interning strings for my own widget(I set a templatePath for my widget). I did not find the reason why.

comment:4 Changed 10 years ago by James Burke

If you attach a sample, simple widget that has a templatePath and a file for the template, then I can try to reproduce.

comment:5 Changed 10 years ago by virsir

Resolution: invalid
Status: closedreopened

OK, i find the reason. It was caused by my own i18n file, I have a default nls file for my own package, nls/nls.js. If i removed this file, the building process works.

comment:6 in reply to:  5 Changed 10 years ago by Adam Peller

Replying to virsir:

OK, i find the reason. It was caused by my own i18n file, I have a default nls file for my own package, nls/nls.js. If i removed this file, the building process works.

There's not enough information here for us to help you. It's best to work this stuff out outside of trac before filing a ticket. You might try the forums or #dojo IRC channel.

comment:7 Changed 10 years ago by virsir

OK, i found the problem still exist. There is some more information:

  1. My system is windows xp, dojo palces at "D:\dev\workspace\dojotoolkit"
  2. I attached a mock project file, please unzip it to put these files just in the dojotoolkit folder.
  3. use command "build version=finance1.0 mini=true loader=xdomain cssOptimize=comments action=release optimize=shrinksafe profileFile=../../js.profile log=1 copyTests=false releaseName=js" to make the build. You should see the error.

Changed 10 years ago by virsir

Attachment: project.zip added

comment:8 Changed 10 years ago by James Burke

"nls" for a bundle name is not supported. I updated the dojo.requireLocalization comments for this in [20397], but still need to update docs.dojocampus.org, so leaving it open until that happens.

comment:9 Changed 10 years ago by virsir

Hi, I changed the name to common.js but it still does not work.

comment:10 Changed 10 years ago by James Burke

Milestone: tbdfuture

The project.zip file's aa.js is malformed, it needs a

dojo.provide("com.aaaaaa.test.testtest.aa");

in it, based on the contents of js.profile.

comment:11 Changed 9 years ago by Al Briggs

I am also having this problem - exactly the same error message - I have only found if I delete the nls directory that I can remove the error.

I am nto sure how to put together a test case - but will try.

comment:12 Changed 9 years ago by Al Briggs

OK I have (with some help from colleagues) found out that my problem has nothing to do with the nls package - but is actually todo with the com namespace we use.

Although the error message I got is as above the error is actually already in trac (#9303) with the relevant solution I thought it was worth noting here with the error message how to solve it.

There are two choices:

  • upgrade to 1.4.0 and use the removeDefaultNameSpaces=true argument when building.
  • modify the 1.3.2 build file as per [20402] and then use the removeDefaultNameSpaces=true argument when building.

This removed the problem for me on the builds.

comment:13 Changed 7 years ago by ben hockey

Owner: changed from James Burke to virsir
Priority: highlow
Status: reopenedpending

Is anyone still experiencing these problems?

If there is no response within 14 days this ticket will automatically close.

comment:14 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.