Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#9691 closed defect (fixed)

Fix BorderContainer slider's _recalc property

Reported by: Adam Peller Owned by: bill
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

_recalc causes a memory leak, according to #9614. Also, the calculation of oppNode should not be done at setup time, since oppNode may not exist yet (or may later be removed)

Change History (4)

comment:1 Changed 10 years ago by bill

Milestone: 1.41.5

Passed cutoff for non-regression bug fixes

comment:2 Changed 10 years ago by bill

Milestone: 1.51.4
Owner: changed from Adam Peller to bill
Status: newassigned

I've got a fix for this.

comment:3 Changed 10 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [20866]) BorderContainer fixes:

  1. Make addChild() call layout() rather than layoutChildren(), so that _computeSplitterThickness() is called (fixes #9881).
  2. Get rid of problematic dijit.layout._Splitter.oppNode parameter where (for example) the left splitter points to right child's domNode. oppNode sometimes had the wrong value (or no value), like when the right child didn't exist when the left splitter was initialized.
  3. Get rid of _recalc property to avoid similar problems, and also because it's an unnecessary optimization; calling computeMaxSize() each time the user drags a splitter is fine, and safer. Even moving by keystroke on IE6 seems fine. (fixes #9691)
  4. Get rid of this._maxSize and this._minSize and just use local variables

!strict

comment:4 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.