Opened 10 years ago

Closed 10 years ago

#9634 closed defect (invalid)

Custom Build and formISOString (first function).

Reported by: yaz_k83 Owned by: James Burke
Priority: high Milestone: tbd
Component: BuildSystem Version: 1.1.1
Keywords: Custom Build Cc: yazad3@…
Blocked By: Blocking:

Description

Hi,

We are using dojo 1.1.1 source build to create a custom build for our project. We have observed that the fromISOString is violently called when we use the custom build, thus degrading performance while rendering those components - we observed this phenomenon with Menus and Dojox Grids.

Some interesting findings were that, it had nothing to do with the fromISOString function but the first function in the profile specific dojo file. We added an empty function x() at the start and that was being fired multiple times (100s of times).

Regards, Yazad Khambata

Attachments (2)

myProject.build.bat (79 bytes) - added by yaz_k83 10 years ago.
myProject.profile.js (1.1 KB) - added by yaz_k83 10 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 10 years ago by Adam Peller

Component: ShrinkSafeBuildSystem
Owner: changed from alex to James Burke

Have you tried this with the current build? If the problem still exists, we'd need specific steps to reproduce this problem.

It's unlikely this is a shrinksafe problem... possibly a build tools problem?

comment:2 Changed 10 years ago by yaz_k83

No i haven't used the current build... I am using packet as the optimization mode... will try with shrinksafe and comments as optimization in the coming week and let you know if this reproduces the problem.

In the mean while please let me know what information I can provide you with to help diagnose the issue?

Thanks.

Regards, Yazad Khambata

comment:3 Changed 10 years ago by yaz_k83

pardon typo,

"I am using packer as the optimization mode"

comment:4 Changed 10 years ago by James Burke

Packer will no longer be a supported build option since it can cause weird side effects.

Hopefully there will be better behavioral results by using shrinksafe.

comment:5 in reply to:  4 Changed 10 years ago by yaz_k83

The only reason we were using packer was because we couldn't reliably use gzip with IE6 sp2. Thanks for the update though.

Replying to jburke:

Packer will no longer be a supported build option since it can cause weird side effects.

Hopefully there will be better behavioral results by using shrinksafe.

comment:6 Changed 10 years ago by yaz_k83

I tried out with optimization options - comments and shrinksafe today and noticed that though individual files change the file dojo.js, and <profile>.dojo.js (and their corresponding uncompressed files) remain binary identical.

However individual files show differences. Is the behavior intended?

Changed 10 years ago by yaz_k83

Attachment: myProject.build.bat added

Changed 10 years ago by yaz_k83

Attachment: myProject.profile.js added

comment:7 Changed 10 years ago by yaz_k83

Hi jbruke,

The above files attached have a mistake from my side - myProject.build.bat does not use layerOptimize. I realized that the default layer optimize is NOT the same as optimize but ShrinkSafe?.

This points to an interesting fact, even though we have been using packer as the optimizer the actual optimizer used (layerOptimizer) so far was shrink safe, and the defect (first function getting called is a defect of ShrinkSafe? and not packer).

Currently I have started using "comments" to solve my problem. We will be using some run time optimization for minifying the files (jawr - http://jawr.dev.java.net).


build profile=myProject action=release cssOptimize=comments optimize=comments layerOptimize=comments


Please let me know if I can be of any help in resolving the root issue. Thank you.

Regards, Yazad Khambata

comment:8 Changed 10 years ago by Adam Peller

If you're using packer, there will be a very distinctive signature at the top of the file, something like

function(p,a,c,k,e,r)

and everything else is pretty well obfuscated. Shrinksafe results are typically just going to look like the original code, without whitespace or comments, and with variables shortened to _a, _b, etc.

The best way to resolve this continues to be for you to reproduce the problem on the latest build with minimal user code, to rule out anything your code might be doing and to make it easily reproducible for us. Discussion or questions on the tools would be better handled in dojo-interest.

comment:9 Changed 10 years ago by yaz_k83

The best way to resolve this continues to be for you to reproduce the problem on the latest build with minimal user code, to rule out anything your code might be doing and to make it easily reproducible for us.

Do you want me to combine the latest Shrink Safe (http://download.dojotoolkit.org/release-1.3.2/dojo-release-1.3.2-shrinksafe.tar.gz) with the stable release of Dojo 1.1.1 (http://download.dojotoolkit.org/release-1.1.1/dojo-release-1.1.1-src.zip) and reproduce the issue? Or are you expecting something else?

Discussion or questions on the tools would be better handled in dojo-interest.

I agree with you here Peller, but the questions were to help reproduce the issue with other optimization modes.

Thanks, Yazad Khambata

comment:10 Changed 10 years ago by Adam Peller

Don't bother mixing Dojo 1.1 with Shrinksafe from 1.3 - there are API changes that will make that difficult and I don't suspect Shrinksafe changes, though anything is possible.

What would help us identify the problem is the simplest possible example on the latest possible release, preferably 1.3 or trunk, for us to reproduce what you're seeing.

comment:11 Changed 10 years ago by James Burke

Resolution: invalid
Status: newclosed

Closing this for now, but feel free to reopen with an HTML test file that indicates the problem. The build profile and build command are helpful, but we will need an HTML file that shows the problem.

Note: See TracTickets for help on using tickets.