Opened 13 years ago

Closed 12 years ago

#963 closed defect (wontfix)

Dojo refuses to compile

Reported by: Pedro Ferreira <ilzogoiby@…> Owned by: James Burke
Priority: high Milestone: 0.9
Component: BuildTools Version: 0.3
Keywords: ant build rhino Cc: ilzogoiby@…
Blocked By: Blocking:

Description

Hello. I tried to build the whole thing through the scripts, but it always fails in the some place. I tried deleting ~/.ant and copying a newer version of rhino, but it fails anyway...

Here's the paste:

mahound@magrathea ~/projects/ext/dojo/trunk/buildscripts $ ./build.sh ajax
Buildfile: build.xml

-check-config:

-fix-config:

release:
     [echo] Using version number: 0.0.0.dev for the release.

clean:
   [delete] Deleting directory /home/mahound/projects/ext/dojo/trunk/release/dojo
     [copy] Copying 536 files to /home/mahound/projects/ext/dojo/trunk/release/dojo/src
     [copy] Copying 117 files to /home/mahound/projects/ext/dojo/trunk/release/dojo/demos
     [copy] Copying 402 files to /home/mahound/projects/ext/dojo/trunk/release/dojo/tests

BUILD FAILED
java.lang.NoSuchMethodError: org.mozilla.javascript.Context.getDebuggableEngine()Lorg/mozilla/javascript/debug/DebuggableEngine;

Total time: 1 second
mahound@magrathea ~/projects/ext/dojo/trunk/buildscripts $

Thanks in advance,

Pedro

Change History (10)

comment:1 Changed 13 years ago by James Burke

This error usually means there is another rhino.jar in your classpath. Dojo uses a custom rhino that is in the buildscripts dir. Make sure there is no other rhino jar in your path, maybe by clearing your classpath before calling ant or as one of the parameters to ant.

comment:2 Changed 13 years ago by James Burke

Cc: ilzogoiby@… added
Milestone: 0.4
Resolution: invalid
Status: newclosed

cc'ing original reporter. Also closing the bug for now, since it is most likely another rhino in the classpath. Please feel free to reopen if that is not the issue.

comment:3 Changed 13 years ago by Pedro Ferreira <ilzogoiby@…>

Resolution: invalid
Status: closedreopened

No, there's no other rhino in the classpath :|.

comment:4 Changed 13 years ago by James Burke

Can you give more information about your environment? Are you using Linux (what distribution)? What is your version of Ant? Is it an Ant build from ant.apache.org (1.6.5 should work)?

There was someone who was using Gentoo, and had build problems here is the thread, but they were resolved by removing any rhino jar (except the ones that come with Dojo), and reinstalling ant using a build from ant.apache.org:

http://dojotoolkit.org/pipermail/dojo-interest/2006-May/007736.html

comment:5 Changed 13 years ago by Pedro Ferreira <ilzogoiby@…>

I'm using Gentoo.

mahound@magrathea ~/projects/ext/dojo/trunk/buildscripts $ ant -v Apache Ant version 1.6.5 compiled on June 14 2006 Buildfile: build.xml Detected Java version: 1.5 in: /opt/sun-jdk-1.5.0.06/jre Detected OS: Linux

Well, I'll read the thread, but it's definitely a strange solution :|.

Thanks,

Pedro

comment:6 Changed 13 years ago by James Burke

Hmm, I think there is something we can do with the classpaths that are used inside the build.xml file to better handle this, and not have the -check-config and -fix-config tasks at all (Just use locally defined classpaths for each task). It has always bothered me that we had to copy jar files to a certain directory.

comment:7 Changed 13 years ago by dylan

is this resolved?

comment:8 Changed 13 years ago by jkuhnert

Milestone: 0.40.5
Owner: changed from anonymous to jkuhnert
Status: reopenednew

The only real way to solve this is by not using ants native javascript task....Completely do-able but sounds like a 0.5 feature to me..

comment:9 Changed 13 years ago by Adam Peller

Owner: changed from jkuhnert to James Burke

We ought to be able to close this now that we're done with ant, at least for basic build tasks?

comment:10 Changed 12 years ago by Adam Peller

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.