Opened 10 years ago

Closed 7 years ago

#9623 closed defect (fixed)

[patch] [cla] Cache issue with dojox.dtl._Templated

Reported by: ID Owned by: ben hockey
Priority: low Milestone: 1.8
Component: DojoX DTL Version: 1.3.2
Keywords: Cc: ben hockey
Blocked By: Blocking:

Description

Cache retrieving is not done properly in dojox.dtl._Templated.

This bug is only triggered when no Django tags are present and the widget is used more than once.

Patch attached

Attachments (2)

templated_test.patch (1.4 KB) - added by ID 7 years ago.
Test case for dojox.dtl._Templated
dojox.dtl._Templated.patch (360 bytes) - added by ID 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by ben hockey

Owner: changed from Neil Roberts to ID
Priority: highlow
Status: newpending

can you provide a test case that demonstrates this problem so that i can confirm if your patch is still needed and what problem it fixes?

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:3 in reply to:  1 Changed 7 years ago by ID

Replying to neonstalwart:

can you provide a test case that demonstrates this problem so that i can confirm if your patch is still needed and what problem it fixes?

I've attached a test case that show how it fails. Basicaly when a template is used with no django tags. I've also updated the patch to the latest revision.

Changed 7 years ago by ID

Attachment: templated_test.patch added

Test case for dojox.dtl._Templated

comment:4 Changed 7 years ago by bill

It says "patch attached" in the description but the only patch is for the tests, right?

Also ID, do you have a CLA filed? And if so, what name is it under?

Changed 7 years ago by ID

Attachment: dojox.dtl._Templated.patch added

comment:5 Changed 7 years ago by ID

Sorry I messed up my diff command. Here is the patch that corrects the bug that I mention.

I just sent my CLA under the name Jérôme Heil

comment:6 Changed 7 years ago by bill

Cc: ben hockey added
Resolution: invalid
Status: closedreopened
Summary: Cache issue with dojox.dtl._Templated[patch] [cla] Cache issue with dojox.dtl._Templated

Ben, you checked in the other patches, maybe you can do this one too.

comment:7 Changed 7 years ago by ben hockey

Milestone: future1.8
Owner: changed from ID to ben hockey
Status: reopenedassigned

sure - i'll take a look and hopefully get to it in the next few days.

comment:8 Changed 7 years ago by ben hockey

Resolution: fixed
Status: assignedclosed

In [28173]:

ensure a cloned dtl template is used. fixes #9623 !strict

Note: See TracTickets for help on using tickets.