Opened 10 years ago

Closed 10 years ago

#9621 closed defect (fixed)

Dijit tree control node label focus problem in IE8

Reported by: iyip2 Owned by:
Priority: high Milestone: 1.3
Component: Dijit Version: 1.2.0
Keywords: dijit tree focus IE8 Cc:
Blocked By: Blocking:

Description

Release 1.2.0, dijit tree control, in IE8 browser, when clicking on the tree node, when script debugging is enabled, will see this error in an alert box: Error: Can't move focus to the control because it is invisible, not enabled, or of a type that does not accept the focus.

and the line of code that is causing the issue is in dijit/tree.js: focusNode: function(/* _tree.Node */ node){ summary: Focus on the specified node (which must be visible)

set focus so that the label will be voiced using screen readers node.labelNode.focus(); },

Can we test if the node is visible/enabled/can accept focus before we try to call focus() on it?

This problem does not happen in Firefox

Change History (1)

comment:1 Changed 10 years ago by bill

Milestone: tbd1.3
Resolution: fixed
Status: newclosed

1.3 is the first dojo version that supports IE8, and Tree is working there.

Note: See TracTickets for help on using tickets.