Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#9599 closed defect (fixed)

DateTextBox: invalid message displayed prematurely

Reported by: bill Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Dijit - Form Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description

Noticed in the DateTextBox automated tests that it prints an "invalid date" tooltip even though the (simulated) user hasn't finished typing the value yet.

See attached truncated version of dijit/tests/form/robot/DateTextBox.html.

Just after typing "1" the error message shows up. It shouldn't be showing anything except maybe a prompt message, right?

I think the issue is because of the programmatic changes to displayValue/value that occur before the focusing into that field and typing.

Attachments (1)

DateTextBox.html (2.1 KB) - added by bill 10 years ago.
truncated version of dijit/tests/form/robot/DateTextBox.html

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by bill

Attachment: DateTextBox.html added

truncated version of dijit/tests/form/robot/DateTextBox.html

comment:1 Changed 10 years ago by Douglas Hays

Milestone: tbd1.4
Status: newassigned

comment:2 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [19323]) Fixes #9599. Fix constraints.max compare logic. Reactivate subset input after old value is cleared out.

comment:3 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.