Opened 10 years ago

Closed 10 years ago

#9598 closed defect (duplicate)

dijit.layout.TabContainer excessively calling onShow of children

Reported by: ben hockey Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.3.2
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by ben hockey)

in the layout method of TabContainer?, there is a call to

this._showChild(this.selectedChildWidget);

which causes onShow to be called on the child.

problem: the resize function inherited from _LayoutWidget has a call to this.layout(); which leads to onShow being called every time the widget resizes.

in my case, each time my tab is shown, i'm refreshing data from the server and unfortunately, this means that every time the window is resized i'm making a call to the server.

i'll probably find a workaround for now, and perhaps this is more of an annoyance than a bug, but it seems to me that calling onShow as a result of a resize is arguably a bug.

Change History (2)

comment:1 Changed 10 years ago by ben hockey

Description: modified (diff)

comment:2 Changed 10 years ago by ben hockey

Resolution: duplicate
Status: newclosed

duplicate of #9345

Note: See TracTickets for help on using tickets.