Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9558 closed defect (fixed)

Editor: tabbing on IE tends to skip back to the beginning of the document

Reported by: bill Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Editor Version: 1.3.0
Keywords: Cc:
Blocked By: Blocking:

Description

Load test_Editor.html. Note that focus is on "Automated test" div. Follow these steps:

  1. tab until focus goes to content of "Created from div" editor
  2. shift-tab until focus is back to beginning "Automated test" div
  3. tab forwards

Bug 1: Note that focus skips back from the first editor to the first <div> in the document (perhaps this bug is related to having an empty toolbar?)

  1. keep tabbing

Bug 2: tabbing from the content of the first editor should go to the toolbar of the second editor (perhaps it will require two tabs, that's a separate ticket), but focus again goes back to the beginning of the document.

Change History (5)

comment:1 Changed 10 years ago by bill

Summary: Editor: initial text not erased by DELETE (FF)Editor: tabbing on IE6 tends to skip back to the beginning of the document

comment:2 Changed 10 years ago by bill

Milestone: tbd1.4
Summary: Editor: tabbing on IE6 tends to skip back to the beginning of the documentEditor: tabbing on IE tends to skip back to the beginning of the document

Happens in 1.3, working in 1.2.

Actually I notice that focus does go to one of the buttons in the toolbar of editor1 but then immediately jumps somewhere else. Maybe some issue w/_KeyNavContainer.

Marking as 1.4 for now although I guess we'd want to backport the fix to 1.3 if we plan another 1.3 release.

comment:3 Changed 10 years ago by Douglas Hays

Owner: set to Douglas Hays

seems to be caused by [16555]

comment:4 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [18873]) Fixes #9558. Needed to remove some focus code added for the Editor refactor in [13977].

comment:5 Changed 10 years ago by bill

(In [19099]) Add test for tabbing and shift-tabbing around the Editor widget. Working on FF and IE, although not safari (but that seems to be a problem with DOH rather than w/the editor?)

Refs #9558, #9612, #8987.

Note: See TracTickets for help on using tickets.