Opened 10 years ago

Closed 7 years ago

#9544 closed defect (wontfix)

Problem with gears storage in Firefox 3.5

Reported by: epx Owned by: Shane O'Sullivan
Priority: low Milestone: future
Component: Storage/Flash Version: 1.3.1
Keywords: Cc:
Blocked By: Blocking:

Description

When Google Gears is NOT installed in Firefox 3.5, Dojo raises the following exception:

google.gears.factory.getPermissions is not a function

It seems that Dojo is fooled by the fact that "google" object exists in global scope, but "google.gears" does not.

This bug did not show up in Firefox 3.{0,1}

Same problem in versions 1.2.3 and 1.3.1

The bug seems to be trigggered by usage of dojox.storage, but code is in dojo/offline. I am not sure which is the right component. I put "Storage/Flash?" because that is what my program is using.

Change History (7)

comment:1 Changed 10 years ago by Adam Peller

the global 'google' is undefined in my FF 3.5. Does this involve some other installation?

comment:2 Changed 10 years ago by Adam Peller

Owner: changed from bradneuberg to Brad Neuberg

comment:3 Changed 10 years ago by dante

Milestone: tbdfuture

comment:4 Changed 10 years ago by Adam Peller

@epx: please provide steps to reproduce this problem. I'm able to run the dojox.storage tests in FF3.5 w/o gears (I think -- it's not obvious what the test is or how it works... we need some doh work here badly if we are to continue to maintain dojox.storage)

comment:5 Changed 10 years ago by Adam Peller

Owner: changed from Brad Neuberg to Shane O'Sullivan

Thank you, Shane

comment:6 Changed 8 years ago by ben hockey

Keywords: needsreview added
Priority: highlow

comment:7 Changed 7 years ago by bill

Keywords: needsreview removed
Resolution: wontfix
Status: newclosed

Gears is deprecated, and FF3.5 is ancient.

Note: See TracTickets for help on using tickets.