Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#9538 closed defect (duplicate)

ComboBox and FilteringSelect textbox reverts back to previous value onBlur if the dropdown list contains same value with different case

Reported by: vmanchal Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.0
Keywords: case senstive options Cc: vmanchal@…
Blocked By: Blocking:

Description

The ComboBox? or FilteringSelect? widget does not allow the user to select the same value with different case in the textbox OnBlur?. For example, if the dropdown options are values "value1", "VALUE1", "value2", "value3"...so on. After user selects "value1", if the user selects "VALUE1" from the dropdown list, onBlur on the textbox, the value reverts back to "value1" again. This happens on all browser and all platforms.

##### code snippet from dijit.form.ComboBox? widget #####

_onBlur: function(){

summary: called magically when focus has shifted away from this widget and it's dropdown this._hasFocus=false; this._hasBeenBlurred = true; this._hideResultList(); this._arrowIdle(); if the user clicks away from the textbox OR tabs away, set the value to the textbox value #4617: if value is now more choices or previous choices, revert the value var newvalue=this.getDisplayedValue();

if(this._popupWidget&& (newvalue==this._popupWidget._messagespreviousMessage?newvalue==this._popupWidget._messagesnextMessage?)){

this.setValue(this._lastValueReported, true);

}else{

this.setDisplayedValue(newvalue);

}

},

########################################

If the else part is commented, everything works fine as expected.

Change History (3)

comment:1 Changed 10 years ago by vmanchal

Please cancel ticket #9537 as it is a duplicate of ticket #9538.

comment:2 Changed 10 years ago by bill

Resolution: duplicate
Status: newclosed

Dup of #9537.

comment:3 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.