Opened 10 years ago

Closed 10 years ago

#9525 closed defect (invalid)

Undefined is null or not an object error in dojo._ieDispatcher

Reported by: bilikiss Owned by: sjmiles
Priority: high Milestone: tbd
Component: Events Version: 1.2.0
Keywords: ieDispatcher Cc:
Blocked By: Blocking:

Description

Error:

'undefined' is null or not an object

This line h[lls[i]].apply(sender, args);

in dojo._ieDispatcher is failing because there is no check against the values to make sure they are not undefined.

This problem only happens in IE with script error notification turned on

Change History (2)

comment:1 Changed 10 years ago by bill

Component: GeneralEvents
Milestone: tbd
Owner: changed from anonymous to sjmiles

Can you give a test case where this happens, or steps to reproduce the problem w/our existing test cases? I remember seeing this in the past but I thought we fixed it aleady.

comment:2 Changed 10 years ago by Adam Peller

Resolution: invalid
Status: newclosed

will reopen if a test case is identified. it could be that the proper args are not used

Note: See TracTickets for help on using tickets.