Opened 10 years ago

Closed 7 years ago

#9523 closed defect (invalid)

dojox.json.ref resolveJson does not correctly handle deletion from array properties

Reported by: dstarke Owned by: dstarke
Priority: high Milestone: tbd
Component: Dojox Version: 1.3.1
Keywords: Cc:
Blocked By: Blocking:

Description

When walking through an object with an array property where an element of that array has been deleted, the new (shorter) version of the array is overwritten with the old longer version of the array, with the result that the deleted element is restored to the array.

This appears to be a regression caused by change #18289. This change added a test for whether the target object has an id attribute before deleting the properties from the target that are no longer present in the desired version of the object. Since the array property does not have an id property, this code is skipped. Reverting this line of code appears to resolve the issue, but I don't know what other issues this may cause.

Change History (3)

comment:1 Changed 10 years ago by Adam Peller

Owner: changed from Adam Peller to Kris Zyp

comment:2 Changed 8 years ago by ben hockey

Owner: changed from Kris Zyp to dstarke
Status: newpending

this looks like it was fixed in r21097. if this issue still exists then please attach a test case. if there is no response within 14 days, this ticket will be closed automatically.

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.