Opened 10 years ago

Closed 8 years ago

#9497 closed defect (duplicate)

dojo.query of [attr$='suffix'] returns non-matching hidden fields

Reported by: Andre Steenveld Owned by: dylan
Priority: low Milestone: 1.8
Component: Query Version: 1.3.1
Keywords: css query needsreview Cc:
Blocked By: Blocking:

Description

The "[attr$='suffix']" query gives some unexprected results. For some reason or another the hidden field is always included when it has the attribute eventhough the suffix of the value doesn't match the query. I have tested this in FF 3.0.11, Opera 9.63 and IE 7. ttrenka tested it in FF 3.5 where it seem to work as expected. Attached are two testcases, one with only form elements and another with a span element aswell.

Attachments (3)

testcase2.html (1.2 KB) - added by Andre Steenveld 10 years ago.
Test cases using spans
testcase.html (1015 bytes) - added by Andre Steenveld 10 years ago.
Test case form elements
hackFix.html (1.6 KB) - added by Andre Steenveld 10 years ago.
Very dirty hack for a temperal fix

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by Andre Steenveld

Attachment: testcase2.html added

Test cases using spans

Changed 10 years ago by Andre Steenveld

Attachment: testcase.html added

Test case form elements

Changed 10 years ago by Andre Steenveld

Attachment: hackFix.html added

Very dirty hack for a temperal fix

comment:1 Changed 10 years ago by dante

Owner: changed from anonymous to alex

comment:2 Changed 10 years ago by bill

Component: CoreQuery

comment:3 Changed 10 years ago by bill

Summary: Unexpected behaviour in dojo.querydojo.query of [attr$='suffix'] returns non-matching hidden fields

comment:4 Changed 10 years ago by James Burke

Milestone: tbdfuture

comment:5 Changed 9 years ago by Chris Mitchell

Owner: changed from alex to dylan

please review/triage

comment:6 Changed 8 years ago by ben hockey

Keywords: needsreview added
Priority: highlow

comment:7 Changed 8 years ago by bill

Milestone: future1.8
Resolution: duplicate
Status: newclosed

Duplicate of #13658.
Fixed as #13658.

Note: See TracTickets for help on using tickets.