Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9492 closed task (fixed)

dijit.tests._base.scroll failure (safari 4)

Reported by: bill Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Dijit Version: 1.3.0
Keywords: Cc:
Blocked By: Blocking:

Description

Doug says this is a safari bug, that they aren't drawing the box the right size. Bug started occurring in safari 4 production (it was working in beta).

Need to file a ticket at bugs.webkit.org, assigning to Doug for that.

     _AssertFailure: doh._AssertFailure: assertEqual() failed:
 	expected
		(0,+38)(0,+1)
	but got
		(0,+30)(0,+1)

 with hint: 
		min failed
: assertEqual() failed:
	expected
		(0,+38)(0,+1)
	but got
		(0,+30)(0,+1)

 with hint: 
		min failed
 doh._AssertFailure: assertEqual() failed:
     expected
		(0,+38)(0,+1)
	but got
		(0,+30)(0,+1)

 with hint: 
		min failed
     ERROR IN:
 		 function test_7036_8665_loose_rtl()

Attachments (1)

webkitbug.html (503 bytes) - added by Douglas Hays 10 years ago.
Example showing incorrect document.compatMode on WebKit?

Download all attachments as: .zip

Change History (4)

comment:1 Changed 10 years ago by Douglas Hays

The problem is that

<iframe src="javascript:'<html></html>'">

is strict mode in Safari.

Changed 10 years ago by Douglas Hays

Attachment: webkitbug.html added

Example showing incorrect document.compatMode on WebKit?

comment:2 Changed 10 years ago by Douglas Hays

Milestone: tbd1.4
Resolution: fixed
Status: newclosed
Type: defecttask

https://bugs.webkit.org/show_bug.cgi?id=27845
Workaround is to specify a DOCTYPE of
<!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.01 TransitionalEN">
for WebKit? when you really want quirks mode and using the javascript: protocol.

comment:3 Changed 10 years ago by bill

FYI, this was worked around in the test file in [18797] (according to Doug).

Note: See TracTickets for help on using tickets.