Opened 10 years ago

Closed 10 years ago

#9482 closed defect (fixed)

DojoX GFX SVG Images do not show

Reported by: Mike Wilcox Owned by: Mike Wilcox
Priority: high Milestone: 1.4
Component: DojoX GFX Version: 1.3.0
Keywords: Cc: Eugene Lazutkin
Blocked By: Blocking:

Description

None of the Image tests work in Safari nor Firefox. The problem has been isolated to the fact that the SVG node should have an xlink naemspace.

http://www.w3.org/TR/SVG11/struct.html#ImageElement

Change History (3)

comment:1 Changed 10 years ago by Mike Wilcox

(In [18536]) Refs #9482 - The SVG Image bug is fixed for Firefox. Setti ng the fill to none caused the image to not display. Safari is not fixed - notes will be in the ticket. Fixed test_image2.html for Safari though, using the workaround.\!strict

comment:2 Changed 10 years ago by Mike Wilcox

The Safari bug is not fixed and is a known bug, although I did open a new ticket for it: https://bugs.webkit.org/show_bug.cgi?id=26897

This issue in *not* in Chrome, just Safari. There is a workaround however, proved out in the gfx/tests/test_image2.html file: Create the image as var img = surface.createImage() Make a group as var g = surface.createGroup() Add to the group: g.add(img);

This will defeat the rendering bug. Most any other hacks failed.

comment:3 Changed 10 years ago by Mike Wilcox

Resolution: fixed
Status: newclosed

Closing this since it works well enough in Safari, and WebKit? has closed their related ticket. Note that the issue is still a little buggy, but this is the browser, not GFX.

Note: See TracTickets for help on using tickets.