Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#948 closed defect (wontfix)

IE7: sorted table test makes each row about 3 inches tall

Reported by: bill Owned by: Tom Trenka
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

On IE7, test_SortableTable.html correctly displays the rows, but each one is about 3 inches tall. Other than that, seems to work.

Change History (5)

comment:1 Changed 13 years ago by Tom Trenka

Bill, are you sure this is a code error and not a CSS one? i.e. (no pun) have you tried the sortable table test without the css in the test file at all?

(I don't have a copy of IE7 installed, it did some funky things to one of my boxes and I've been holding off ever since)

comment:2 Changed 13 years ago by bill

Nope, I'm not sure of anything, but I meant that test_SortableTable.html was failing; since you wrote that test (and SortableTable? itself) I was hoping you could take a look

comment:3 Changed 13 years ago by Tom Trenka

Sure, will do.

comment:4 Changed 13 years ago by Tom Trenka

Resolution: wontfix
Status: newclosed

I'm going to close this bug, as it's a CSS-specific problem that has nothing to do with the functionality of SortableTable?, and everything to do with MS's inability to get the CSS spec right. Basically, the issue is this rule:

html>tbody{ height: 262px; overflow:auto; ... }

IE7 is incorrectly interpreting that to mean "tr"; not only is the height not being applied only to the tbody element but it is also completely ignoring the overflow setting.

Sigh.

Either way, the functionality of the widget (even though I'm going to remove it version 0.5 or 0.6) is still correct.

comment:5 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.