Opened 10 years ago

Closed 10 years ago

#9479 closed defect (worksforme)

IE, xdomain load i18n resource error

Reported by: virsir Owned by: anonymous
Priority: high Milestone: tbd
Component: General Version: 1.3.0
Keywords: xdomain ie Cc: dante, James Burke
Blocked By: Blocking:

Description

please test below simple test in IE.

<script src = "http://ajax.googleapis.com/ajax/libs/dojo/1.2.3/dojo/dojo.xd.js"> </script> <script>

dojo.require("dojo.number");

</script>

Attachments (1)

test.html (142 bytes) - added by virsir 10 years ago.
testcase

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Adam Peller

Resolution: worksforme
Status: newclosed

Please use attach to attach a complete test and include actual results with your report. Thanks.

Changed 10 years ago by virsir

Attachment: test.html added

testcase

comment:2 Changed 10 years ago by virsir

Resolution: worksforme
Status: closedreopened

OK, i added the testcase, you can just open the file with IE, you will see some js errors.

comment:3 Changed 10 years ago by Adam Peller

I see no errors. It would be helpful to know exactly what error you see, as well as platform and locale info.

comment:4 Changed 10 years ago by virsir

I tested with IE6/Chinese locale windows and IE7/English locale windows, it all have problem.

"Line 8, Error: expected ")". and then another error: "Exception thrown and not caught"

And I found the error only happens when dojo try to load some i18n resources.

comment:5 Changed 10 years ago by Adam Peller

Cc: dante James Burke added

Ok, I wasn't sure if it was ok to just load SCRIPT tags with out a full HTML document, but apparently that makes no difference. I can't recreate the problem. Can anyone else? If anyone can catch this in a debugger (visual studio or IE8's) it might be interesting, but it sounds like it's choking on the first non-ASCII character (line 8 in dojo/cldr/nls/zh/number.js)

My guess was that there's an encoding problem, but all of the files are being served up explicitly with charset=UTF-8 in the headers.

comment:6 Changed 10 years ago by virsir

Hi, I do not know whether it was caused by my own ie environment, I found this problem just gone some day.

comment:7 Changed 10 years ago by Adam Peller

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.