Opened 10 years ago

Closed 10 years ago

#9426 closed defect (fixed)

Editor regression: text indent function removed in [13262]

Reported by: Douglas Hays Owned by: bill
Priority: high Milestone: 1.3.2
Component: Editor Version: 1.3.0
Keywords: Cc: Adam Peller, liucougar
Blocked By: Blocking:

Description

#6408 [13262] removed the ability to use the indent/outdent function in Editor for plain text. Currently it only works within a list. This breaks backward compatibility and is preventing some customers from upgrading. The change should either be rolled back, or at least reenabled/disabled with a boolean flag for compatibility. The function behavior is somewhat browser dependent, but some customers were using it as-is.

Change History (7)

comment:1 Changed 10 years ago by Douglas Hays

(In [18417]) References #9426 !strict. An Editor unrefactor regression. Firefox was not getting styleWithCSS set to false which caused generated blockquotes to be changed to div tags. insertBrOnReturn removed from _mozSettingsProps (RichText?.js) since it was set by blockNodeForEnter=='BR' which was only defined in the EnterKeyHandling? plugin.

comment:2 Changed 10 years ago by Douglas Hays

If we just remove the indent/outdent if/else from queryCommandEnabled then all the browsers generate blockquote tags and there doesn't seem to be any real inconsistencies other than Firefox has a default right margin while IE and Safari specify a right margin = 0. I don't think there's any value-add in trying to prevent the user from indenting their list items more than once to start with. They may have a reason to do so and it doesn't seem to hurt anything. This ticket should also be considered for inclusion in 1.3.2 since it was a removal of existing function.

comment:3 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [18437]) Fixes #9426 !strict. Remove special handling of indent/outdent letting browsers handle natively to restore the function removed in 1.2.

comment:4 Changed 10 years ago by Douglas Hays

Cc: Adam Peller added; Douglas Hays removed

I'd like to get this approved for 1.3.2 since it fixes both a refactor backout mistake and also reinstates removed function.

comment:5 Changed 10 years ago by bill

OK, sounds fine to me.

comment:6 Changed 10 years ago by Douglas Hays

Milestone: 1.41.3.2
Resolution: fixed
Status: closedreopened

comment:7 Changed 10 years ago by Douglas Hays

Resolution: fixed
Status: reopenedclosed

(In [18531]) Fixes #9426 for 1.3.2. Restored indent/outdent back to 1.1 functionality.

Note: See TracTickets for help on using tickets.