Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#9378 closed defect (fixed)

Editor does not allow custom P styling (MS Word) to be pasted

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Editor Version: 1.3.0
Keywords: Cc: liucougar
Blocked By: Blocking:

Description (last modified by Douglas Hays)

Run test_Editor.html in IE.
Load the MSWord.doc attachment in MS Word and copy all the text to the clipboard.
Focus the Editor widget labeled "Created from div" and paste the MS Word text. Everything is shifted to the left.
Pressing the getValue button causes the bullets to appear but the left margins are still collapsed.

Attachments (2)

MSWord.doc (44.0 KB) - added by Douglas Hays 11 years ago.
MS Word doc with custom P styling
9378.patch (1.4 KB) - added by Douglas Hays 11 years ago.
remove !important from default P CSS and avoid converting P tags with custom styling into BR tags

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by Douglas Hays

Attachment: MSWord.doc added

MS Word doc with custom P styling

Changed 11 years ago by Douglas Hays

Attachment: 9378.patch added

remove !important from default P CSS and avoid converting P tags with custom styling into BR tags

comment:1 Changed 11 years ago by Douglas Hays

Cc: liucougar added
Description: modified (diff)

comment:2 Changed 11 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [17924]) Fixes #9378. Remove !important from default P CSS and avoid converting P tags with custom styling into BR tags.

comment:3 Changed 10 years ago by bill

(In [18404]) Code reduction for _fixNewLineBehaviorForIE() (refs #2859), plus fixing IE8 console exception when using BR mode for EnterKeyHandling?, caused by [17924] (refs #9378).

!strict

Note: See TracTickets for help on using tickets.