Opened 10 years ago

Closed 10 years ago

#9365 closed defect (duplicate)

IE: dijit.Editor Setting of font size causes document position to be lost.

Reported by: Jared Jurkiewicz Owned by: Douglas Hays
Priority: high Milestone: 1.4
Component: Editor Version: 1.3.1
Keywords: Cc:
Blocked By: Blocking:

Description

IE: dijit.Editor Setting of font size causes document position to be lost.

When experimenting with the dijit.Editor on IE 7, I see the following bad behavior.

Using testcase: dijit\tests\test_Editor.html

The editor created under heading: Optional toolbar buttons This one shows various font sizes and provides a toolbar for changing them

The problems are the following:

1.) Highlight and resize text does not work: Highlight some text, then click the 'Size' dropdown. The highlight is lost and the text isn't resized. Furthermore, it repositions the entry cursor to the top of the text being edited. I could do this in Firefox 2 and Safari 3.2.3, just not in IE.

2.) Entering resized text at the end does not work. Click in the editor, then arrow down to the bottom of the page, then press enter a few times to get a blank line. Then click the size dropdown to seyt the font size. The entry cursor moves back to the beginning of the document and sets resized text to insert there. I couldn't get it to let me insert larger text at the bottom, for example. I could do this in Firefox 2 and Safari 3.2.3, just not in IE.

Change History (2)

comment:1 Changed 10 years ago by Jared Jurkiewicz

Owner: changed from liucougar to Douglas Hays

Testpatch for editor issues caused these problems.

comment:2 Changed 10 years ago by Douglas Hays

Milestone: tbd1.4
Resolution: duplicate
Status: newclosed

Regresion caused by the original patch in 9274. This is now fixed with the refreshed 9274_trunk.patch.

Note: See TracTickets for help on using tickets.