Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#9318 closed defect (worksforme)

Dojo button widgets losing onClick when below the page fold

Reported by: Laura_ Owned by: Douglas Hays
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.3.1
Keywords: Cc: nic
Blocked By: Blocking:

Description

If the user clicks on a form widget (e.g. Button widget) that's below the page fold, not only will the widget's onClick not fire for the first click, but the browser will 'jump' to the very top of the page and lose where the user was. The user has to then scroll back down to the button and click it again for it to work.

To see an example, load the test page in Firefox: http://download.dojotoolkit.org/release-1.3.1/dojo-release-1.3.1/dijit/tests/form/test_Button.html Then shrink the browser vertically a bit (so the page doesn't neatly fit on the screen), and scroll down until one of the button widgets on the bottom of the page is visible. Note that clicking on the button widget will cause the browser to 'jump' back to the top of the page.

You have to scroll back down to the button widget and click it again to have it actually fire.

The problem does not happen if you didn't have to scroll down to reach the button widget.

Attachments (1)

scrollOnFocus.html (769 bytes) - added by nic 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by nic

A quick and dirty workaround is to set scrollOnFocus to false on your buttons. The test_Button.html page works for me, I'll attach another test page.

comment:2 Changed 10 years ago by nic

Cc: nic added

Changed 10 years ago by nic

Attachment: scrollOnFocus.html added

comment:3 Changed 10 years ago by bill

Owner: set to Douglas Hays

Hmm, I've tried on both FF/win and FF/mac (3.0.10) and I can't reproduce this. What version/platform is your firefox? You are just using the mouse to click, right?

comment:4 Changed 10 years ago by Douglas Hays

Resolution: worksforme
Status: newclosed

I tested on Linux/FF3.1b2 and WinXp?/FF2 and I didn't see any auto-scrolling with either test_Button.html nor with scrollOnFocus.html. If it's still a problem, please reopen with more specific environmental details.

comment:5 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.