Opened 10 years ago

Closed 10 years ago

#9306 closed defect (duplicate)

can not reload grid after fetch error

Reported by: Aleksey Owned by: Bryan Forbes
Priority: high Milestone: tbd
Component: DojoX Grid Version: 1.3.0
Keywords: Cc:
Blocked By: Blocking:

Description

need add "this._pending_requests[req.start] = false;" to "_onFetchError: function(err, req){" (as in "_onFetchComplete: function(items, req){") in DataGrid?.js

this flag does't give to make new fetch:

_fetch: function(start, isRender){
		var start = start || 0;
		if(this.store && !this._pending_requests[start]){

Change History (1)

comment:1 Changed 10 years ago by Nathan Toone

Resolution: duplicate
Status: newclosed

Dupe of #9158

Note: See TracTickets for help on using tickets.