Opened 10 years ago

Closed 9 years ago

#9272 closed defect (worksforme)

GridContainer - DnD Broken

Reported by: Mike Wilcox Owned by: Shane O'Sullivan
Priority: high Milestone: 1.5
Component: Dojox Version: 1.3.0
Keywords: GridContainer, DnD Cc: Shane O'Sullivan
Blocked By: Blocking:

Description (last modified by Shane O'Sullivan)

This issue occurs only in Firefox. IE and Safari seem to work as intended (although if there is supposed to be an avatar, they don't)

This issue can be seen in the tests. When dragging a container it jumps to the bottom of the screen until the end of the drag. The test recovers and places the container, but in the client's app, the placement does not work - the container hides.

Change History (14)

comment:1 Changed 10 years ago by dante

This has been around for a bit, and I've yet to find the cause and or a solution. Patches welcome.

comment:2 Changed 10 years ago by dante

Cc: Shane O'Sullivan added
Milestone: tbdfuture

shane is slowly becoming the defacto owner of GC ;)

comment:3 Changed 10 years ago by Shane O'Sullivan

Milestone: future1.4.1
severity: normalmajor

There is DND breakage in the dojox.widget.Portlet tests too. In IE, the dragged node disappears when dragging in the first tab, and never reappears. This is not a Portlet issue, as I have tried removing all the Portlet code so that the widgets are just TitlePanes?, and it still occurs.

Have any changes gone into DND over the last few months?

comment:4 Changed 10 years ago by jfcunat

I was the initial commiter of the GC. But not have been too much involved in the evolution of it. We have developed a new version with a reworked dnd. Are you interested in reviewing the new version ?

comment:5 Changed 10 years ago by Shane O'Sullivan

Yes, I'm certainly willing to take a look. What are the main differences? Does it still use Dojo DND? Can you attach the code and test sameples?

comment:6 Changed 10 years ago by Shane O'Sullivan

Owner: changed from dante to Shane O'Sullivan

comment:7 Changed 10 years ago by Shane O'Sullivan

Description: modified (diff)

comment:8 Changed 10 years ago by jfcunat

New GridContainer? does not use anymore dojo dnd. This means that you really move portlet nodes and not an avatar, it does not rely on mouseover either but depends on coordinates (much more successful on IE when dealing with a lot of portlet). I am trying to attach the code and samples before Christmas !

comment:9 Changed 10 years ago by Mathevet julien

I am interested too. I have some problems with new gridContainer inheritance and with StackContainer? child. Mailny due to GridContainer? doesn't manage size... But new dodjo Dnd has been reworked to remove corrdinate method, due to CPU utlization. So I am not sure it's a great idea to change with your code. Or use new name for this new gridContainer.

comment:10 Changed 10 years ago by Shane O'Sullivan

Has there been any more development on this new GridContainer?? I'd love to see an example. IE6 performance is a real problem for the current one.

comment:11 Changed 10 years ago by Adam Peller

Milestone: 1.4.21.5

comment:12 Changed 9 years ago by Shane O'Sullivan

The GridContainer? has been more or less completely rewritten, and checked in for 1.5

Is this still an issue? If it is no longer reproducible, this ticket can be closed

comment:13 Changed 9 years ago by Mike Wilcox

Shane, I reported this on behalf of a client, so I haven't been monitoring the progress at all. If you feel it's good to go, please close.

comment:14 Changed 9 years ago by Shane O'Sullivan

Resolution: worksforme
Status: newclosed

Closing as I cannot reproduce this issue, and the GridContainer?, along with the new dojox.mdnd module, have been completely rewritten for 1.5

Note: See TracTickets for help on using tickets.